Download


Known problems

Requirements

Works best with Opera 9.5, Firefox or Safari. Other modern browsers might work too.
Opera is the only browser that has support for both the widget and the panel.
Sorry IE users, it does NOT work with IE. There are better browsers you can switch to.

Download

Windows: LiquoricePlayer_1_0_beta_1.exe (Version 1.0 Beta 1)

Download - Mirrors

Free Download

Updates

You can subscribe to the RSS feed to get news about new releases!

Changelog

Beta 1 - 26 Jun 2008

  • First public beta release.